CONFIGURATION TEXT

access-list 1 permit 192.168.1.2 0.0.0.255
access-list 1 deny any



interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 10
 ip address 192.168.1.254 255.255.255.0
!
interface FastEthernet0/0.2
 encapsulation dot1Q 20
 ip address 192.168.2.254 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0
 ip address 172.15.0.2 255.255.255.252
!


!
router rip
 network 172.15.0.0
 network 192.168.1.0
 network 192.168.2.0


access-list 1 permit 192.168.22.0 0.0.0.255
access-list 1 deny any

access-list 2 permit any
access-list 2 permit 192.168.10.0 0.0.0.255

interface FastEthernet0/2
 switchport access vlan 10
 switchport mode access

interface FastEthernet0/24
 switchport access vlan 20
 switchport mode access

interface FastEthernet0/1
 switchport mode trunk



interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.2.1 255.255.255.0
!



interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.4.1 255.255.255.0


router ospf 100
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.0.0 area 0


hostname R2
!
ip cef
!
ip vrf BLUE
 description Trusted Traffic
!
ip vrf RED
 description Guest Traffic

interface Serial0/0/0 >>ubah kepada serial
 description R3
 no ip address
 duplex auto
 speed auto
!
interface Serial0/0/0.10 >>ubah kepada serial
 encapsulation dot1Q 10
 ip vrf forwarding BLUE
 ip address 10.0.23.1 255.255.255.252
!
interface Serial0/0/0.20
 encapsulation dot1Q 20
 ip vrf forwarding RED
 ip address 192.168.23.1 255.255.255.252
!
interface FastEthernet0/0 >>ubah kepada fa0/0
 description S1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip vrf forwarding BLUE
 ip address 10.0.1.1 255.255.255.0
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip vrf forwarding RED
 ip address 192.168.1.1 255.255.255.0
!
router ospf 1 vrf BLUE
 router-id 0.0.2.1
 log-adjacency-changes
 network 10.0.0.0 0.0.255.255 area 0
!
router ospf 2 vrf RED
 router-id 0.0.2.2
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
end

CONFIGURATION ON CISCO ROUTER

HOW TO CONFIGURE CISCO ROUTER

Make coonection from pc to router using console cable



 Connect using putty or hyperterminal


>>setup ip and force to up for interface fa0/0
Command
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fa0/0 *
Router(config-if)#ip address 172.16.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#exit
Router#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]


·         *insert yourinterface port ether fa0/1, s0/1, s0/0

Do routing protocols for router
What is Routing Protocols?
A routing protocol specifies how routers communicate with each other, disseminating information that enables them to select routes between any two nodes on a computer network. Routing algorithms determine the specific choice of route. Each router has a priori knowledge only of networks attached to it directly. A routing protocol shares this information first among immediate neighbors, and then throughout the network. This way, routers gain knowledge of the topology of the network.


Routing Protocols : OSPF, EIGRP, RIP
Command:
Router>ena
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router eigrp* 1
Router(config-router)#network 172.16.0.0
Router(config-router)#network 172.10.0.0
Router(config-router)#network 192.168.3.0
Router(config-router)#no auto-summary
Router#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]

·         *ospf/rip




*TO BE CONTINUE ACL













CISCO 2600 BACKUP AND RESTORE IOS

HOW TO BACKUP IOS CISCO ROUTER 2600
USING TFTP SERVER

      1.       Instal tftp server

      

2.       Edit configuration file
C:\OpenTFTPServer/OpenTFTPServerMT.ini


3.       Uncomment and edit
Before
After
‘write=N
Write=Y
‘Overwrite=N
Overite=Y




4. Save
>>Run OpenTFTP Server


5. Connect cross cable from port fa0/0 on router to network card on pc.
Change ip on pc to static ip





6. Connect console from router to pc. Using hyperterminal to access into router


7. Open file goto new connection




8. Insert name and choose icon


9. Select connection.. like me use COM1.

10. Choose speend rate. It important when use tftp server to transfer ios from server to your router.



11. Now you are connected to your router



12. Set ip address for port fa0/0.
>>Router#configure terminal
>>Enter configuration commands, one per line.  End with CNTL/Z.
>>Router(config)#interface fastEthernet 0/0
>>Router(config-if)#ip address 10.1.1.2 255.255.255.0
>>Router(config-if)#no shutdown



13. Test connection




14. Check flash file




15. Copy flash file to tftp server


16. Check file on tftp server folder
>>C:\OpenTFTPServer



17. DONE TO TRANFER FLASH TO TFTP SERVER


HOW TO RESTORE FLASH TO CISCO 2600 ROUTER

1. Check cable are connected
2. Run tftp server (see above)
3. Open hyperterminal (see above)
>>Set ip address on router
               Rommon 1>IP_ADDRESS=10.1.1.2
               Rommon2>IP_SUBNET_MASK=255.255.255.0

               Rommon3>DEFAULT_GATEWAY=

(IF TFTP SERVER AT OUTSIDE NETWORK RANGE, YOU MUST SET GATEWAY. LIKE ME,  MY TFTP SERVER IN THE SAME RANGE OF NETWORK SO DONT NEED TO PUT GATEWAY)
               Rommon4>TFTP_SERVER=10.1.1.1  <<YOUR IP SERVER
               Rommon5>TFTP_FILE=c2600-d-mz.122-13b.bin <<file name have to move
              
               Rommon6>tftpdnld –r
(when hit the enter, file from server will move to your router. Wait the file finish to finish transfer.)

Done transfer



4. Set ip address
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip add 10.1.1.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#
(if server at outside range of network,you must configure ip route)


6. Copy tftp flash from server



7. Reload



 8. DONE!!!! ;)







CentOS Installation On Virtual Box

Open Source Operating System

*tips for install package into linux/unix/windows.. must know step by step

1) install
Exp : install + samba + centos
2) Configure
3) Start Service
4) Test Service

Example :
      1)      #yum install samba
      2)      #nano /etc/samba/sub.conf
      3)      #/sbin/service sub start
      4)      Test from other pc(wiindows pc) using ip address server

Text Editor : nano, vi, uim, pico


How to install CentOS on Virtual Box

1)      Open/run your virtual box


2)      Move your cursor to new tab



3)      Next





4)      Write down your virtual os name and choose type of os and then click Next


5)      Choose your virtual RAM



6)      For the first time using virtual OS, you can choose start up with create new hard disk or can use existing hard disk if have. I choose create new hard disk.


7)      choose the type of file that you would like to use for the new virtual disk


8)      choose the type of file that you would like to use for the new virtual disk


9)      Virtual disk file location and size



10)   Finish create new hard disk


11)   Click start tab



12)    Welcoming interface


13)   Choose iso location




14)   Start


15)   Press enter to install



16)   Skip to scan media



17)   Next


18)   Select language




19)   Select the appropriate keyboard


20)   Yes



 21)   Select next if you new install CentOS. If you in mode advance, you can modified partition of hard disk


22)   Network configuration



23)   Select time zone


24)   Write you admin (root) password. NOTE- you must remember you password



 25)   Additional package have to install on centos. Make sure you have internet access to update packages.


26)   Next



27)   Reboot after complete installation


28)   Forward



29)   Firewall


30)   SELinux



31)   Date and Time


32)   Create user



33)   Sound Card


34)   Finish


35)   Insert username




36)   Insert password


37)   Welcome to CentOS 5